Meteor update on OS X hangs


#1

I am trying to do meteor update in one of my project folders, but after downloading the install alway hangs at the same spot (when looking at the node process)

/private/var/folders/xc/62_b8y394rd80mk7781ccq880000gn/T/.tmp1f8kwgs/meteor-tool-1.4.0/mt-os.osx.x86_64/isopackets/cordova-support/npm/node_modules/meteor/babel-compiler/node_modules/json5/lib/json5.js

and the command line just keeps spinning

 meteor update
   Downloading meteor-tool@1.4.0...          /                                     

has anybody else seen this and knows how to fix it?


#2

So am I.
Because I am in China,I think it blocked by GFW :poop:

meteor update --release 1.3.5.1
Downloading meteor-tool@1.3.5_1…
Downloading meteor-tool@1.3.5_1…
Downloading meteor-tool@1.3.5_1…
Downloading meteor-tool@1.3.5_1…
Downloading meteor-tool@1.3.5_1… /

may be you should check your network and try again


#3

I did the curl https://install.meteor.com/ | sh thing, which removed $HOME/.meteor and installed 1.4 properly.

Unfortunately now I have the same issue with 1.3.5_1. A project I don’t want to update yet is trying to download its version of meteor and hangs at

/private/var/folders/xc/62_b8y394rd80mk7781ccq880000gn/T/.tmp37gx73/meteor-tool-1.3.5_1/mt-os.osx.x86_64/isopackets/constraint-solver/npm/node_modules/meteor/modules/node_modules/acorn/dist/acorn.js


#4

Had to restore .meteor/packages/meteor-tool from TimeMachine backup because something is totally broken with meteor right now


Meteor-tool@1.1.10 keep showing downloading
#5

Great, meteor 1.4.0-1 got released and now creates the same problem where every meteor related action hangs trying to download and install meteor-tool@1.4.0-1

This one doesn’t get past

/private/var/folders/xc/62_b8y394rd80mk7781ccq880000gn/T/.tmpj0i47g/meteor-tool-1.4.0-1/mt-os.osx.x86_64/dev_bundle/mongodb/bin/mongod


#6

@jamgold and others - We’re investigating this issue right now, please bear with us.


Meteor 1.4 just released!
Heavy CPU use after tool update to 1.4
#7

The workaround posted earlier was to change the sym link in ${HOME}/.meteor to the previous version

lrwxr-xr-x    1 jhm  staff    10 Jul 29 10:31 meteor -> meteor1351
lrwxr-xr-x    1 jhm  staff    52 Jul 29 10:07 meteor1351 -> packages/meteor-tool/1.3.5_1/mt-os.osx.x86_64/meteor
lrwxr-xr-x    1 jhm  staff    50 Jul 27 22:51 meteor140 -> packages/meteor-tool/1.4.0/mt-os.osx.x86_64/meteor

and the update finished


#8

I had this on the first try today, going from 1.4 to 1.4.0.1 on OS X. It hung for about two hours. Finally I killed the process, tried it again and it worked immediately. Everything running smoothly now, and I didn’t reconfigure or delete anything between those first and second tries.


#9

Same here, stuck on first update, kill process, re-run and it finished update to 1.4.0.1.


#10

I’m seeing this currently. With a freshly-installed 1.4.0.1, running “meteor update” on a project with .meteor/release “none”, ramps up cpu, and seems to hang, ctrl-C and kill doesn’t work, requires a kill -9. dtruss shows lots of madvise, mmap, and munmap, then some gettimeofday, then reporting nothing (but still running). Killing and restarting the update still hangs. This is OS X 10.11.5.

Update, resolved mine: Looks like the meteor app I was trying to update used some local packages (in .meteor/packages, and a ./packages dir). After removing those, it seemed to update okay.


#11

Same thing on Linux Ubuntu 16.04


#12

Same here. I’m trying to run a Legacy version of Telescope, which uses Meteor 1.2.1. Trying to build on Linux Ubuntu 16.04 but it hangs on Downloading meteor-tool@1.1.10...