Meteor Windows Preview 0.2.0 with new installer


#1

Hi Meteor forums!

As some of you may know, @slava, @avital, and I have been working hard on official Windows support for Meteor. We believe we are pretty close to completion of one of the most requested features in the history of Meteor.

Tonight, we are releasing a new preview version - WINDOWS-PREVIEW@0.2.0.

We unwittingly broke meteor update in the previous release, WINDOWS-PREVIEW@0.1.7, so use the new installer to update. Download it from the Windows preview Wiki page.

The biggest change in this release is the installer, which has been rebuilt completely using the popular WiX installer toolkit. If it doesn’t work for you, please report a bug on the Windows preview issue tracker.

Thanks so much to everyone who has been testing these releases so far - we wouldn’t have gotten this far without your continued feedback.


Type of installer use in Meteor 2.0 Windows preview?
#2

If we already have it installed would you prefer we use the installer to update?


#3

Yes, it would be extra helpful to see how the installer works for that case! I’ll edit my original post to reflect that.


#4

Installed fine. Though it sat at Installing Meteor... at about 20% for ~45 seconds or so and then made it to 100% in about 1 second. :smile:

After that I ran meteor --help and it downloaded meteor-tool@1.1.0-winr.8. First I saw a progress bar that took only about 10 seconds and then a spinner for about 60 seconds. Then I saw the expected output.

meteor update appears to have worked fine and I was prompted to create a Node.JS exception in the firewall.

Pretty normal stuff!


#5

Did you run meteor --help from inside an app?


#6

The first thanks, I try run meteor update but show:

C:\Users\Theara>meteor update

C:\Users\Theara\AppData\Local\.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.w
indows.x86_32\tools\server\mini-files.js:18
  if (p[0] === "\\" && (! partialPath)) {
       ^
TypeError: Cannot read property '0' of undefined
    at toPosixPath (C:\Users\Theara\AppData\Local\.meteor\packages\meteor-tool\1
.1.0-winr.12\mt-os.windows.x86_32\tools\server\mini-files.js:18:8)
    at Object.convertToStandardPath (C:\Users\Theara\AppData\Local\.meteor\packa
ges\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\server\mini-files.js:55
:12)
    at Object.files.getHomeDir (C:\Users\Theara\AppData\Local\.meteor\packages\m
eteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\files.js:1165:13)
    at defaultWarehouseDir (C:\Users\Theara\AppData\Local\.meteor\packages\meteo
r-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\tropohouse.js:30:43)
    at Object.<anonymous> (C:\Users\Theara\AppData\Local\.meteor\packages\meteor
-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\tropohouse.js:39:42)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)

#7

This could be a bug in the tool that looks up the currently installed version by inspecting the meteor.bat script. What do you think, @sashko?


#8

How does this get along with EACH-IN@0.0.3?
(sorry, I am still confused about Meteor installation/update process)


#9

That seems possible - we changed the script at the last moment, but I didn’t think that would affect the script parsing because it was just changing the way the installation directory env var was set.

Here’s the commit: https://github.com/meteor/meteor/commit/9f0f91e85118bff81cf74d27aafffc26d033e778

Does it look like it would break the parsing?


#10

Same error when I run meteor update


#11

Got the same error over here (meteor update)

Updated using the installer. It’s such a shame that the Windows version is behind :frowning: I need to use Telescope but I can’t because it uses 1.0.3.1 :frowning:


#12

Seemed to install fine, but getting an error when I try to run any meteor whatever commands:

C:\Users\Kevin Guldenaar>meteor --help

C:\Users\Kevin Guldenaar\AppData\Local\.meteor\packages\meteor-tool\1.1.0-winr.11\mt
-os.windows.x86_32\dev_bundle\lib\node_modules\fibers\future.js:245
                                                throw(ex);
                                                      ^
TypeError: Cannot use 'in' operator to search for 'track' in null
    at C:\Users\Kevin Guldenaar\AppData\Local\.meteor\packages\meteor-tool\1.1.0-win
r.11\mt-os.windows.x86_32\dev_bundle\lib\node_modules\underscore\underscore.js:8
61:18
    at Array.forEach (native)
    at _.each._.forEach (C:\Users\Kevin Guldenaar\AppData\Local\.meteor\packages\met
eor-tool\1.1.0-winr.11\mt-os.windows.x86_32\dev_bundle\lib\node_modules\undersco
re\underscore.js:79:11)
    at Function._.pick (C:\Users\Kevin Guldenaar\AppData\Local\.meteor\packages\mete
or-tool\1.1.0-winr.11\mt-os.windows.x86_32\dev_bundle\lib\node_modules\underscor
e\underscore.js:860:5)
    at [object Object]._.extend.getDefaultReleaseVersion (C:\Users\Kevin Guldenaar\A
ppData\Local\.meteor\packages\meteor-tool\1.1.0-winr.11\mt-os.windows.x86_32\too
ls\catalog-remote.js:849:14)
    at Object.release.latestKnown (C:\Users\Kevin Guldenaar\AppData\Local\.meteor\pa
ckages\meteor-tool\1.1.0-winr.11\mt-os.windows.x86_32\tools\release.js:185:41)
    at C:\Users\Kevin Guldenaar\AppData\Local\.meteor\packages\meteor-tool\1.1.0-win
r.11\mt-os.windows.x86_32\tools\main.js:846:29

#13

Downloading meteor-tool@1.1.0-winr.12 -
Forever update on Windows 10 Technical Preview from version 1.0.7.


#14

Downloaded and installed…

The Install progress bar completed to 100%* before anything happened, then meteor downloaded - ver steady 1% at a time increase.

After download it went ‘installing’ meteor but there was nothing to indicate activity because the progressbar was already at 100% but after a while, it changed to ‘publishing’ and then quickly to meteor installed.

*This could be a wix issue as I’m installing on win 2003 server - to give you an edge case :wink:

meteor update on a simple app with couple of packages
Dowloading meteor-tool@1etc outputs 1 line per every iteration of the progress bar (1000s of lines) then it hangs for a while…

Then I get same error as @theara


#15

Yes, I did.

(Extra characters here for forum’s sake.)


#16

Used the installer on top of the previous version.

The first time it gave me this error: http://pastebin.com/gnsnLjw8 (it might be a problem related to my firewall, it didn’t download anything), but ran it again and it installed successfully.


#17

What are the Meteor versions packaged into these Windows releases?


#18

I get the following error messing while doing a ‘meteor update’ on my windows machine:

C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.
windows.x86_32\tools\server\mini-files.js:18
if (p[0] === “\” && (! partialPath)) {
^
TypeError: Cannot read property ‘0’ of undefined
at toPosixPath (C:\Users\user1\AppData\Local.meteor\packages\meteor-tool
1.1.0-winr.12\mt-os.windows.x86_32\tools\server\mini-files.js:18:8)
at Object.convertToStandardPath (C:\Users\user1\AppData\Local.meteor\pack
ages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\server\mini-files.js:5
5:12)
at Object.files.getHomeDir (C:\Users\user1\AppData\Local.meteor\packages
meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\files.js:1165:13)
at defaultWarehouseDir (C:\Users\user1\AppData\Local.meteor\packages\mete
or-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\tropohouse.js:30:43)
at Object. (C:\Users\user1\AppData\Local.meteor\packages\meteo
r-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\tropohouse.js:39:42)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)
at require (module.js:380:17)


#19

These releases are coming straight off of devel, so they are actually the most up-to-date releases available.


#20

Great news. Will try it tomorrow, hope that rebuilding the app is fixed by now.