Meteor Windows Preview 0.2.0 with new installer


#21

Hey it turns out that the previous release (0.1.7) had a broken meteor update. The solution is to just use the new installer to get 0.2.0.


#22

I did now remove the old meteor installation and used the new installer. However, I get the following error, when I try to run meteor:

C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.
windows.x86_32\dev_bundle\lib\node_modules\fibers\future.js:245
throw(ex);
^
TypeError: Cannot convert null to object
at hasOwnProperty (native)
at Function..has (C:\Users\user1\AppData\Local.meteor\packages\meteor-to
ol\1.1.0-winr.12\mt-os.windows.x86_32\dev_bundle\lib\node_modules\underscore\und
erscore.js:1074:27)
at [object Object].
.extend.loadUnibuildsFromPath (C:\Users\user1\AppData
\Local.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\iso
pack.js:622:11)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\tropohouse.js:469:19
at Array.forEach (native)
at Function.
.each..forEach (C:\Users\user1\AppData\Local.meteor\package
s\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\dev_bundle\lib\node_modules\und
erscore\underscore.js:79:11)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\tropohouse.js:468:11
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:352:18
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:345:34
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:343:23
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at Object.enterJob (C:\Users\user1\AppData\Local.meteor\packages\meteor-t
ool\1.1.0-winr.12\mt-os.windows.x86_32\tools\buildmessage.js:317:26)
at Object.download (C:\Users\user1\AppData\Local.meteor\packages\meteor-t
ool\1.1.0-winr.12\mt-os.windows.x86_32\tools\tropohouse.js:410:20)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\tropohouse.js:544:22
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:352:18
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:345:34
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:343:23
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at Object.enterJob (C:\Users\user1\AppData\Local.meteor\packages\meteor-t
ool\1.1.0-winr.12\mt-os.windows.x86_32\tools\buildmessage.js:317:26)
at [object Object].
.extend.downloadPackagesMissingFromMap (C:\Users\user1
\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\t
ools\tropohouse.js:541:20)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\main.js:431:30
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:264:13
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:257:29
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:255:18
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:246:23
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at Object.capture (C:\Users\user1\AppData\Local.meteor\packages\meteor-to
ol\1.1.0-winr.12\mt-os.windows.x86_32\tools\buildmessage.js:245:19)
at Object.catalog.runAndRetryWithRefreshIfHelpful (C:\Users\user1\AppData
Local.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\cata
log.js:92:31)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\main.js:430:17
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:264:13
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:257:29
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:255:18
at [object Object]..extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\buildmessage.js:246:23
at [object Object].
.extend.withValue (C:\Users\user1\AppData\Local.meteo
r\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools\fiber-helpers.js
:115:14)
at Object.capture (C:\Users\user1\AppData\Local.meteor\packages\meteor-to
ol\1.1.0-winr.12\mt-os.windows.x86_32\tools\buildmessage.js:245:19)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\main.js:428:33
at [object Object]._.extend.withProgressDisplayVisible (C:\Users\user1\App
Data\Local.meteor\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\tools
\console.js:612:14)
at springboard (C:\Users\user1\AppData\Local.meteor\packages\meteor-tool
1.1.0-winr.12\mt-os.windows.x86_32\tools\main.js:427:11)
at C:\Users\user1\AppData\Local.meteor\packages\meteor-tool\1.1.0-winr.12
\mt-os.windows.x86_32\tools\main.js:1005:5


#23

Meteor 0.2.0 works great so far. Great job mdg.


#24

@theara, @risul, @jktr, did you solve your issue? I did a clean install and get this same error with any meteor xxxxx command…


#25

The reason of this error is that any call to meteor alone (to run an application) changes the meteor.bat file from:

@echo off
set METEOR_INSTALLATION=%~dp0%
"%~dp0\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\meteor.bat" %*
rem %~dp0\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\meteor.bat

to:

@echo off
"%~dp0\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\meteor.bat" %*
rem %~dp0\packages\meteor-tool\1.1.0-winr.12\mt-os.windows.x86_32\meteor.bat

(and it also triggers the error described by @hellstad)

I am solving this by manually adding back the missing line after each call to meteor. Any help would be greatly appreciated…


#26

Solved this by re-creating the application with a fresh meteor create.

Beware: the first time, when copying my application files back, I restored the .meteor folder content and removed the local folder only. This didn’t work. I had to remove everything, keeping only my packages file.

This is the second time I spend time on this kind of issue. Am I the only one to find the Meteor install process obscure? Is there a place where I can find doc about what kind of files goes to %LOCALAPPDATA%/.meteor? To myapp/.meteor? To myapp/.meteor/local? What really happens when doing meteor create? What really happens when doing meteor update? What really happens when when MDG pushes a new version? When a package owner pushes a new version?

Sorry, I’m a bit frustrated but it will pass quickly :- )


#27

Hi Steve,

also on my side the upgrade process showed the same difficulties. I.e. setting up a new project with meteor create xyz worked well. Upgrading an exiting project showed errors (meteor upgrade, meteor run, meteor reset).

I am hoping for the official 1.1.0 release, which will probably have solved these little issues. I can understand your frustration - on the other hand, the benefits of this advanced framewok outweigh by far our little troubles.

Cheers,

Joachim


#28

The issue happened again when I updated to EACH-IN@0.0.3. I am now staying away from this version and it seems to work well.


#29

hello im a beginner, but when i tried to run meteor on windows it says

‘meteor’ is not recognized as an internal or external command, operable program or batch file

here is the PATH:

C:\Users\ilastra\AppData\Local.meteor\

a little assistance would be appreciated thank you so much


#30

it seems like my computer does not have .meteor folder in the AppData\Local\


#31

Interesting! Did the installer look like it succeeded?


#32

hello @sashko below are series of images i took when i installed meteor on my local laptop running in windows 7…

above notice when i tried to sign in, it says Unknown Error so i just hit ok then clicked on Skip this step

<img src="/uploads/default/1272/ed8265f5d2aa8369.JPG"width=“300” height=“120”>

it seems like the installation went ok however when i type meteor it did not run anything nor if i type meteor --help. and notice that on the folder it does not have .meteor on it.

is it me or is this meteor for windows is only for servers? im apologize for being such a newbie

warm regards
Ian


#33

Have you tried uninstalling and reinstalling?


#34

hello @sashko,

yes i have tried it but still no good… :frowning:

i am excited to try meteor on windows… :frowning:


#35

The installer uses WiX so maybe you could generate a log of what it’s doing? http://wixtoolset.org/documentation/manual/v3/howtos/general/get_a_log.html

PD: I also got the sign in error and just skipped the step as well. Does that step simply call meteor login?


#36

That’s cool! But as a Windows user, I don’t know if I want to go back to using Meteor on Windows though… I used to use it, then I ran into a brick wall - ah right, the version available in the unofficial port was stuck in 0.8.3 I think and I had to look into using virtualbox. Maybe the Meteor team can officially support an easy deployment method using Vagrant? This one by user Sanjo made it almost painless and I like the rsync setup provided:


#37

The Windows Preview installed smoothly for me and the todos example is working fine. Also installed Robomongo which I find very helpful and it appears to be working fine with the environment as well.

Tried to add info below to the Tools for… Meteor Windows wiki page, but couldn’t (not sure if the page permits collaborators).

Robomongo for Windows - GUI DB Management Tool

http://robomongo.org/

Robomongo is a shell-centric cross-platform open source MongoDB management tool (i.e. Admin GUI).


#38

I installed meteor for Windows 0.3.0 successfully. However I don’t understand the versioning. Does this Windows 0.3.0 corresponds to Meteor 1.0.4 ?


#39

Both Windows and other version will be same version as of 1.1.0 if I recall correctly


#40

Will add this! Looks like a great tool.