Question regarding template naming convention

is it bad practice to use _ in template naming
such as template_name vs. templateName vs. template-name

You are already not allowed to use dash - in your template names, so it leaves you with few options. I personally prefer templateName or if I want to pseudo-namespace them, I do something like MNtemplateName where MN is Module Name.

can you provide a few examples of modules?

from MDG’s Meteor Style Guide

Use camelCase for identifiers

Functions should be named like doAThing, not do_a_thing.

Other variable names get the same treatment: isConnected, not is_connected.

Originally Meteor used a different convention, in which underscores were sometimes encouraged. But now we’ve moved everything over to camelCase to match common JavaScript convention. If you see old inchworm_style identifiers you’re encouraged to convert them. There are a few places in public APIs where inchworm_style aliases are provided for backward compatibility.

it’s just a pseudo namespace.

for example a user list template would be part of my accounts module so I
would name it like ACuserList

It’s just a shorthand to help me organize/recognize code and help the ide
help me with better code completion