Stuck at "Starting your app"


#1

I’ve installed the latest version of meteor 1.4.2.3 and simply trying to create my first meteor app. The steps are simple but the process keeps looping on “Starting your app”.

I’ve searched for solutions and tried the following with no success: meteor update, changing the port, npm install, meteor reset, uninstall and reinstall.

Stuck at “Starting you app” seems to be a common issue with no consensus on solution.

Please someone help!


#2

One thing I do is confirm that the project release number matches the installed version of meteor.

What setting do you find in the file <your proj>/.meteor/release?
What does the command meteor --version return when run outside your project directory?


Starting App/Updated Doesn't Finish
#3

Not too sure I did this properly but it appears it’s meteor 1.4.2.3 inside and outside the project.


#4

And I just created the app after the install of Meteor so there shouldn’t be a version issue.


#5

Ok. If your file <your proj>/.meteor/release contains the same thing, then you’ve eliminated that possible reason.

I know nothing about using Meteor under Windows. You’d risk fewer issues working in a Linux virtual machine in Windows using Virtual Box or VMWare, in my opinion.


#6

The meteor windows version has been out for 18 months. I would hope it works by now.

I appreciate your effort in helping me. I might have to consider working in a Linux virtual machine in Windows.

Anyone else come across this issue in Windows?


#7

I would greatly appreciate any input from the community about this issue.

Thank you!


#8

Do you have any mapped/linked/remote file systems? They are known to cause problems with Meteor on Windows.


#9

I have the myapp (app created with Meteor) file setup in a folder on my desktop. How would I determine if the folder is a mapped/linked/remote file system? Through the folder properties?


#10

Basically, yes. This article may help: https://devtidbits.com/2009/09/07/windows-file-junctions-symbolic-links-and-hard-links/


#11

All folders don’t appear to be mapped/linked/remote file systems.

folder type: file folder
attributes: read-only
sharing: not shared


#12

Attempting to create another myapp file in a different folder and the same issue persists.


#13

Can you post a screen of the loop when you are trying to start your app?


#14


#15

I tried to enlarge the image with no success. It’s readable if you increase your screen size.


#16

Just for the heck of it, try creating a new app in c:\temp or something to eliminate that “Meteor.js” folder in your path.


#17

I tried creating the new app in a new folder with no success.

Here’s hoping the new official Meteor release is out soon and solves the issue.

Thank you for the suggestion.


#18

I am still having this issue :open_mouth: on 1.4.2.3


#19

Let’s hope the official release of METEOR@1.4.3 solves this issue.

That’s basically what I’m waiting for.


#20

I just randomly ran into this too. Showing debug info reveals nothing helpful.

EDIT: Going into the project folder and running rm -rf .meteor/local/bundler-cache fixed it.