Stuck at Updating Package Catalog


#1

Hi,
I am trying to add an npm package via meteor add but I have been stuck at Updating Package Catalog for more than an hour now. My question is could there be a problem with my connection or there is a problem with meteor servers although the latter is less likely.

EDIT
It seems that when I enter the meteor add command it starts well then drops to 0 usage of internet so I do not know if its a loss of connection between the server and my computer or something else. I’m in Nairobi.

Any help will be appreciated.
Regards.


#2

The same thing happened to me just now, but it just lasted no more than 5 minutes. Have you tried creating another project just for the sake of testing the connection out?


#3

I’m experiencing this too when I wanted to run meteor update in order to go from 1.3.4.1 to 1.3.4.4.

I figured out that I could update the version number in .meteor/release, and when I then ran meteor it would update everything to 1.3.4.4. I will still get stuck if I run meteor update, but now I don’t have to.


#4

Yeah, same here. See my post here Updating package catalog - packages.meteor.com down

I don’t know if using offline catalog would help you though for an update…


#5

I am facing the same issue when adding d3js package. Hope this gets resolved very soon


#6

Finally it worked :)…Thakyou


#7

I’m facing the same problem.


#8

Same here! There was about an hour period yesterday when it was stuck at Updating package catalog when I tried to add a package. It was fine again, and now again it is hanging up. I tried pinging atmospherejs.com in terminal and I got 100% packet loss, but their client site is accessible. Strange…


#9

Seeing this as well.