Upgrade 1.7 Issue with @babel/runtime

Hello, after upgrading 1.7, I’m getting below error, it happens after installing @babel/runtime if I don’t install of course it throws some missing modules errors.

W20180804-15:20:47.159(3)? (STDERR) D:\Work\nosqlclient\.meteor\local\build\programs\server\boot.js:475
W20180804-15:20:47.258(3)? (STDERR) }).run();
W20180804-15:20:47.258(3)? (STDERR)    ^
W20180804-15:20:47.259(3)? (STDERR) 
W20180804-15:20:47.259(3)? (STDERR) Error: Cannot find module '@babel/runtime/helpers/builtin/interopRequireDefault'
W20180804-15:20:47.259(3)? (STDERR)     at Function.Module._resolveFilename (module.js:547:15)
W20180804-15:20:47.259(3)? (STDERR)     at Function.resolve (internal/module.js:18:19)
W20180804-15:20:47.260(3)? (STDERR)     at Object.require (D:\Work\nosqlclient\.meteor\local\build\programs\server\boot.js:288:32)
W20180804-15:20:47.260(3)? (STDERR)     at makeInstallerOptions.fallback (packages\modules-runtime.js:604:18)
W20180804-15:20:47.260(3)? (STDERR)     at Module.require (packages\modules-runtime.js:230:14)
W20180804-15:20:47.260(3)? (STDERR)     at require (packages\modules-runtime.js:244:21)
W20180804-15:20:47.261(3)? (STDERR)     at livedata_connection.js (D:\Work\nosqlclient\.meteor\local\build\programs\server\packages\ddp-client.js:147:30)
W20180804-15:20:47.261(3)? (STDERR)     at fileEvaluate (packages\modules-runtime.js:322:7)
W20180804-15:20:47.261(3)? (STDERR)     at Module.require (packages\modules-runtime.js:224:14)
W20180804-15:20:47.261(3)? (STDERR)     at require (packages\modules-runtime.js:244:21)

Use version 7.0.0-beta.55. Version 7.0.0-beta.56 lost the “builtin” folder

1 Like

Hello @rjdavid, thx for the help but already tried this, unfortunately somehow it doesn’t bring builtin folder even it seems they got it here: https://github.com/babel/babel/tree/v7.0.0-beta.55/packages/babel-runtime/helpers

Oh my bad, forgot the tilde :smiley: thx for the help did the trick !!

I’m having this same issue, so I changed the beta from beta.56 to beta.55 in the package.json, then ran

meteor npm install, but still get the error.

Any help on what I’m doing wrong is appreciated.

Delete node_modules/@babel then repeat meteor npm install

Ok, tried that, and I presume it’s now installing beta 55. I see it re-install. Still getting the @babel/runtime error when I run meteor command.

Can you check if node_modules/@babel/runtime/helpers/builtin folder exists?

It does not exist. I see only the esm folder inside helpers.

Then you might still be using version 7.0.0-beta.56. Please recheck your package.json and ensure it is beta.55, delete @babel folder then do meteor npm install

this is what I have in package.json:

  "dependencies": {
    "@babel/runtime": "^7.0.0-beta.55",
    "bcrypt": "^2.0.1",
    "highcharts": "^6.1.1",
    "meteor-node-stubs": "^0.3.2",
    "shelljs": "^0.8.2"

is the ^ symbol the issue? Sorry, I’m still learning about npm and package versions.

Yes. Remove the caret symbol (^) to fix the version until you upgrade to version 1.7.1 in the future

1 Like

You rock! Thank you very much.

Thank you, rjdavid. I was like huh what s happened to meteor past few hours with that errors. Your message saved my time if I didn’t find this forum!