Very long wait times downloading meteor-tools on update


I’ve been waiting for Meteor to update for daaaaaaaaayz !?!


Hi guys, I’m running into this same issue here in Brazil, SP, when starting my application, the Meteor try to download the meteor-tool@1.3.4_4 but it always closes the connection in 60% - 80%, and then, I get the following error:

      throw error;

Error: ENOENT: no such file or directory, open '/tmp/mt-1v1pxnc/os.json'

Any solution? I just can’t work because of that, and it’s really worrisome!



Same waiting issue for meteor-tool@1.4.1 here from congo… I start to dislike the meteor-thing…


Same problem, stuck on spinner


Manual installation on windows works for me (~147MB package):


I have exactly the same issue, and have no idea what to do…


Anyone knows what is happening with meteor tool?
When I run my project, meteor starts with download of meteor-tool, and after some percentage of downloading is completed (>50%) it gives me this error:

throw error;

Error: ENOENT: no such file or directory, open ‘/tmp/mt-1v1pxnc/os.json’


Same here.
Downloading meteor-tool@1.4.1_1… still spinning for 18 hours now (started yesterday)
I’m on OSX, in Europe (NL), high bandwidth fixed network connection.


I found with build a lot of update issues were fixed.

When I have encountered spinning in the past I have tried this:

  1. meteor create test
  2. cd test
  3. meteor update (this removes dependencies on a lot of packages that can cause problems)
  4. note: v1.4.1.1 is a patch so try meteor update --patch for that version.

Another thing to check is #7689, make sure there is no random tar.exe or 7z.exe on your path. also cited #67 and #7688.

And lastly, to compile binaries it is good to have node-gyp installed:

meteor npm install node-gyp -g


Updating a few production apps to and Mongo 3.2. It’s all going well except, every time I need to update a machine to, I’ve got an hour plus wait for the tool to download (if it downloads at all) and then the nervous minute or two after download to see whether it hangs indefinitely or installs and becomes usable.

EDIT: Must just be China. Downloaded the tool in less than a minute on a box in Argentina.

My question is …

Having successfully downloaded the tool once, is there a way to just ftp it (whatever it is that gets downloaded) to other machines and somehow be able to “register its presence” (as the tool) on the next machine and use it there, rather than going through the epic download process each time?


Any idea? Because I have same problem here


Eventually I updated all the machines and it all works. It was just a bit of a pain waiting for the downloads.


In my case, the lag was caused by Windows Defender, which seems to go crazy over the update
Turning it off solved the problem


Testing out Meteor 1.5 with a project and immediately get the looooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooonnnnnnnnng wait Downloading meteor-tool@1.5.0

I’m gobsmacked that after all this time MDG ignores such a pain point in developer UX.
It’s like they don’t actually want you to use the product.