Very long wait times downloading meteor-tools on update


I’m curious if anyone else is experiencing this problem. I consistently stay up to date with the latest version of Meteor and often use the beta and release candidate versions. However every time I do an update, it seems to download the meteor-tool fast with the progress bar hitting 100% then it gets stuck on a spinner.

I’ve currently been stuck on Downloading meteor-tool@1.3.3-rc.-0... for about 10 minutes.

I have multiple development environments and the problem seems to occur across the board. This environment is a Windows 10 box and it’s also done it on a Windows 8.1 and a OS X environment.

As I’m typing this it just finished, so about 10 minutes in total. Is anyone else having this issue and is there anything that can be done to fix that? Or is it just one of those things that, since you shouldn’t be updating too often, go make yourself a sandwich?


About the issue - "I'm stuck on 'Downloading meteor-tool@' whenever running any projects."

I have same issue with Meteor 1.3.3. @nbrady did you find any solution?


This issue appears to be related to the CDN MDG is using, and is being tracked here:


Thanks for your attention. I read the issue but what’s the working solution? :worried:



According to @hwillson, currently the meteor-tool install server is down, so use the version that is working already several days before in my computer.

I find the version in the path/to/project/.meteor/release file, it’s METEOR@ This means there’s a working version of meteor of on my machine.

So I run the command:

meteor create --release YourProjectName

This skips the update process and uses the version that it already available on my machine.

As for the update, I think we can just wait for the server to go back to normal and then update. For now the previous release will work.


The solution @hustlion provided looks good to me. Just to add - the CDN issue isn’t affecting everyone; the issue appears to be selective based on geographic location. Definitely add your voice to that issue though, with any additional details you can provide (like location, IP, CDN data center you’re hitting, etc. - see @serkandurusoy’s last comment on that issue thread to get an idea of the details that will help MDG troubleshoot).


Yep! Every piece of information helps!


###Guys pay attention to don’t re install meteor until this issue exist. Because:
I try re install meteor with curl | sh command and It’s remove and install 1.3.3 successfully but then I can’t run my previous project and currently I can’t do anything with my projects (I can’t run project because it’s try to download and again very long wait times downloading meteor-tools and unfinished download) and my computer.

I also try to re install and re back to last stable state with curl | sh but it’s return below output and error:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 6673 0 6673 0 0 3337 0 --:–:-- 0:00:01 --:–:-- 3336
Downloading Meteor distribution
############################################################### 88.7%
curl: (18) transfer closed with 17550809 bytes remaining to read

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now
Installation failed.

My working computer totally was destroyed at all. :sob: :cry:


Guys I also experiencing the same with the download tool 1.3.3_1 since last week. I noticed this one when I try to add meteor add iron:router and it takes the whole day and it did not complete. I tried to reinstall the meteor and it remove the previous version now I cant create even a single app. This is my second week of trying hope that this will be solved ASAP.By the way I’m from Philippines is my country part of the location that cannot


This is a HORRIBLE problem for me. Launching Meteor has taken 45 minutes, and counting!


Well, I give up. I guess Meteor no longer works at all. :angry:


Pure speculation here, I’m not experiencing these problems. But could using the “Slow Start (for developers)” method of running meteor help you guys? I currently run the “release-1.4” branch of Meteor this way as my development platform (found myself requiring Node 4 for an NPM module I needed). It has been very stable for me.

The benefit from the perspective of people in this thread might be getting more from and less from other locations that aren’t working well.

Of course, if you’re not running a Linux environment with all of the build tools already present, it might be too much to tackle. I found it very easy running Ubuntu 16.04.


Thank you for the thoughtful reply. The last release seems to have fixed the CDN issue (or whatever it was), so I’m not going to mess with the Slow Start guide for now, but I appreciate the link and will consider it if there are other bugs like this down the line.


Leave it run overneight. Kill the process and restart several time. Keep waiting.
That’s all I could advise.

My whole team is suffering from this issue, which made me regret the choice of meteor.


I’m running into this same issue.

It seems that every time there’s a major Meteor update, there will be problems with the firsts versions of that update.
Happened before to me, going from 1.2.1 to 1.3
Previous workaround was to make a clean “meteor create”, copy all files from the project a reinstall all packages.
Didn’t test that this time, yet.


Stuck with "Downloading meteor-tool@1.3.4_4"
Any workarounds guys?


I’m trying to run the todos app from the Guide, and I’m stuck on “Downloading meteor-tool@1.3.4_4”. Similarly to others, the initial download completes, but then it hangs with the spinner. (the spinner does spin, but it never actually completes)


Make sure you have good internet connection.
Make sure your PC is not made out from wooden planks.

If these conditions are met its(sadly) normal for meteor-tools download(+spinner) to last 10 min.
If not, its normal(sadly) for meteor-tools download(+spinner) to last 60+ min.

Don’t even try to update through mobile internet. It hurts.


Well, I left it over night, and the damn thing has WORKED! :slight_smile: I had previously left it for at least two hours - just perhaps, I did have a network problem on that occasion, or maybe I just didn’t leave it long enough. Thanks gothicimage.


thanks it worked for me