What's blocking you from updating to Meteor 1.2?


#1

Meteor 1.2 has a lot of changes, and we want people to be able to get started with it as soon as possible. If you haven’t upgraded yet, what’s stopping you?


Making Your App 'Update Proof'
#2
=> Errors prevented startup:

   While building the application:
   [secret]/client/stylesheets/app.scss:40:9: Scss compiler error: file to import not found or unreadable:
   .meteor/local/build/programs/server/assets/packages/meteoric_ionic-sass/ionic
   Current dir: [secret]/client/stylesheets/

#3

It was xolvio:cucumber, but I’m not sure if thats still a blocker (havent looked at it after the weekend).


#4

No officially released SASS compiler on Atmosphere.


https://atmospherejs.com/fourseven/scss


#5

It’s seem meteor 1.2 have trouble when install npm module have peerDependencies


   npm ERR! Problems were encountered
   npm ERR! Please correct and try again.
   npm ERR! extraneous: fbjs@0.2.1 /Users/nguyenphu/Workspace/Sanbox/untitled/packages/mui/.npm/package-new-1d1zxlv/node_modules/fbjs
   npm ERR! extraneous: react-dom@0.14.0-rc1 /Users/nguyenphu/Workspace/Sanbox/untitled/packages/mui/.npm/package-new-1d1zxlv/node_modules/react-dom


#6

Build time is 50% slower! - https://github.com/meteor/meteor/issues/5269
I’m sticking with 1.1 for now.


Slow startup times +1
#7

For some unknown reasons all server method calls fail for us in 1.2.


#8

The SASS compiler issue looks to be resolved.


#9

I was hoping that the updated Cordova implementation would already include a fix for the hot code reload issues (which tend to break the whole app). Since I have to integrate Meteor manually into my Cordova app (it’s hybrid and hence not a matter of just calling meteor update), I don’t want to make this effort twice.

Besides this, I’ve read about so many side-effects after the update (e.g. problems with mquandalle:bower) that I am a bit hesitating to do it for my major project (the app). I updated to Meteor 1.2 in my side-project, but did not notice any improvements which would really bring my app forward. On the contrary, the build times are slower now, opposed to what had been promised. On my Mac, I always see a “linking” message that I was not there in 1.1 and that takes a lot of time. The only reason why I am still on 1.2 in this app is that Jasmine is broken in 1.1 at the moment, due to a build tool bug.

Plus, I’m using SASS instead of LESS, so I would only profit from the build improvements for the precompiler once fourseven:scss is supporting this. I’ve already mentioned in another thread that I don’t think focusing on LESS is a good idea, since SASS is the more advanced framework (e.g. there’s nothing like compass in LESS).


#10

What’s stopping me is that I’ve seen at least a dozen posts in these forums about something that broke after updating to 1.2. Also, looks like rolling back can be a headache. I do want to update, though, so am wondering whether it is possible to update in only one git branch of my code base.


#11

Heads up, I am one of the bunch that did update, but just to keep up with the latest and greatest. I (for now) see no advantage though, so I can understand why people might be hesitant. For me (as a non-pro!), it did open my eyes over the fragile state the package system seems to be in. That seemed to bring the most problems for others. For me, the only really annoying thing is that build times (osx) have been increased a lot. Even when the initial reason I tried 1.2 was that one of the release notes said that the build times would have been improved :slight_smile: (I talked about this in the pre-release thread as well, but got no response).


#12

It’s no longer a blocker. An update has already been released.


#13

I’ve updated some of my meteor apps to 1.2. In most cases there was a bit of (easily resolved) drama with package versions. In all cases, the build times were noticeably longer for app startup and file-changes (I’m using OSX), which was a bummer.


#14

The lack of Node 0.10.40 in EPEL repo (RHEL/CentOS)


#15

Is this for deployment?


#16

Yep. Not a major problem though. Just have a policy of using supported repos. We’re not actually done with 1.2 migration/testing yet anyway!


#17

Upgraded. Ran app, got entirely blank screen. No errors on the command line but tons of “Uncaught TypeError: Cannot set property ‘guid’ of undefined” in the js console. Fuhgeddaboutit, I’m rolling back.


#18

Same error I had and why I reverted back to 1.1,

Materialze.css is causing this and the package isn’t fixed yet. See this pull request:


#19

Too much change, still too buggy, not enough clear benefits.

To be frank, many of our apps are still at 1.0.4. There’s a community of folks who built Blaze apps during 0.x days, and suffered countless breaking changes leading up to 1.0. Things like Windows support, Angular, and React don’t help those of us trying to go into production with Blaze apps. There’s little value there. So, we’re pulling up the rear, and no longer working on the bleeding edge.

That’s not to say ES2015 and Windows support wouldn’t be nice. But we’re waiting till everything has good test coverage, and will be upgrading with enterprise style change-management processes.


#20

The extent of the ES2105 coverage isn’t fully documented anywhere I can see. I keep running into little things that I expected to be supported but are not, such as certain types of argument destructuring, default function parameters, and a problem I just ran into involving subclasses (github issue: https://github.com/meteor/meteor/issues/5351). I keep testing code in Babel’s online code editor, and then it doesn’t work when I copy and paste it into a Meteor app.

If I knew beforehand exactly which features would break, then I guess I could avoid those for now, although having to use only part of the language makes the whole prospect of using ES2015 in Meteor feel a lot less like a good idea.

On the bright side, packaging in 1.2 is working fine for me, and the build system is running much faster than it used to. This is on ubuntu 15.04 64-bit.