Why does the MDG group not talk about which version of node to use?

It seems that a lot of people have issues with node versions and package incompatibility.
Nowhere in the examples does it mention which version of node to use to ensure a stable development environment.

Please, instead of starting all examples with “install meteor”, start off with “make sure this " " version of node is installed”. Or better yet, make a list matching meteor and node versions.

That would eliminate a lot of confusion and maybe solve a good percentage of posts in the forum.


P.S. What is the current version of node that people are using with 1.2?

I dont know, Meteor have it’s own so I do not need to care.


meteor 1.2.1 uses node v0.10.40

on linux you can finde the node bin in:

~/.meteor/packages/meteor-tool/1.1.10/mt-os.linux.x86_64/dev_bundle/bin for meteor 1.2.1

Thank you sir. That is quite helpful.
It is a far cry from shock’s rather snide answer.

I do appreciate it.


You’ll want to checkout the history.md on the MDG repo. It will tell you the latest Node you can use for each major version (1.2 specifies but 1.2.3 does not). In general you should always read this change log every time you upgrade to make sure there are not other breaking changes.

Searching for 0.10 with the find command works pretty well (until we get to upgrade to 4.x!)

Hope this helps!

@mrphilbert Meteor does not use a globally installed node, but bundles its own version (which also has support for fibers compiled in). So there is no need to install your own node before installing Meteor.

Good point. it’s only needed if you’re deploying your app (except for Galaxy).

1 Like

This is not my experience.

I’ve had issues on my DO server because I had node directly installed at the 0.10.36 and when upgrading it required 0.10.40. My deployments failed until I upgraded the node instance installed on my server…

See here: