Windows 10 : Meteor with Mongo/React


#1

Can anyone help me getting back on track? I have been stuck for almost an entire day.

Was running practicalmeteor:mocha and my command line just went crazy, text everywhere. I have tried so many things and nothing has fixed it.

I have: Restarted computer several times. Deleted .meteor/local/ contents. Uninstalled practicalmeteor and reinstalled. Uninstalled meteor and reinstalled it. Tried other meteor projects.

So what can I do? I can post screenshots.
I also have a second question, how do I dev meteor with Ubuntu on Bash. When the files are on windows and run on Bash on Windows it cannot build MongoDB since it does not have permissions. Thank you for your time.


#2

Did you try removing practicalmeteor:mocha and instead using meteortesting:mocha?

The docs are located at https://atmospherejs.com/meteortesting/mocha


#3

I have not . Although you can see how messed up my command line is.


#4

Well at a quick glance it looks like you’re just failing one test case and fixing that should solve your problem, right? Did you look at what that specific case is testing for and the red output you see in the browser?

Why not fix that, and then run the test with meteortesting:mocha and then see if all’s pretty again :wink:


#5

Lol thanks, I tried that meteortesting:mocha. It is not the same so I uninstalled and reinstalled practical. This fixed the issue at the moment.

I am just even more confused on why my terminal just went crazy throwing data all over the place. This is only happening when I run meteor or meteor npm test. I am new to meteor development(one month) on windows and I don’t think that is normal.

I also wish WSL worked with MongoDB but that was a rabbit hole that had no real solution. :expressionless::thinking::sunglasses:


#6

It might make sense to delete the node_modules folder from the root of the app and delete the local folder from the .meteor folder and then run

meteor npm install
meteor run

to see if this sorts out any package/module cache issue. Also try to make sure you’re running on the latest meteor and the latest versions of the packages you’re using. Try to remove some complementary packages that you’ve added but perhaps not using and add them gradually.

It would also help to copy and paste the actual errors you see on the browser and on the server console because it is hard to make sense of them from this screenshot.

Finally, other people have been reporting success with WSL, so if you’re having problems with that, it would be better if you’ve created a separate topic, described what you’re doing and what errors you’re getting exactly.


#7

Awesome, I have deleted the node_modules and ran npm install. It seem to have it kinda working.

This copy paste thing is a real problem since my command prompt seems to be glitched up or something.

This started with this error.

Error: EPERM: operation not permitted, unlink 'C:\Users\admin\meteor\atumesa\.me
teor\local\dev_bundle'
    at Error (native)

Then I started to run meteor reset between running meteor and meteor npm test.
Then the command prompt started glitching and its hard to see all the data meteor is printing.


#8

Hm, are you sure you have installed meteor with the latest choco install meteor method and that you are running all npm commands as meteor npm install prefixing them all with meteor?


#9

The later yes, meteor npm install.

meteor list also produces this command prompt error
meteor --help does not produce this error
meteor does produce this error in command prompt

once meteor is running and I use another window
meteor mongo does not produce this error

Also I have a 64 bit machine. How do I know that it is running meteor 64bit?
When building it states building for windows 32…


#10
C:\Users\brgey\meteor-projects\notes>meteor npm test

> short-lnk@ test C:\Users\brgey\meteor-projects\notes                                                          C:\Users\brgey\AppData\Local\.meteor\packages\meteor-tool\1.4.2_3\mt-os.windows.x86_32\dev_bundle\lib\node_modules\meteor-promise\promise_server.js:190
      throw error;
      ^

Error: EPERM: operation not permitted, symlink 'C:\Users\brgey\AppData\Local\.meteor\packages\meteor-tool\1.4.2_3\mt-os.windows.x86_32\dev_bundle\server-lib\node_modules\' -> 'C:\Users\brgey\AppData\Local\Temp\meteor-test-run1e7lu2n\.meteor\local\build\programs\server\node_modules'
    at Error (native)
    at Object.fs.symlinkSync (fs.js:897:18)
    at Object.wrapper (C:\tools\fs\files.js:1535:35)
    at Object.files.cp_r (C:\tools\fs\files.js:501:11)
    at C:\tools\fs\files.js:488:13
    at Array.forEach (native)
    at Object.files.cp_r (C:\tools\fs\files.js:475:25)
    at C:\tools\fs\files.js:488:13
    at Array.forEach (native)
    at Object.files.cp_r (C:\tools\fs\files.js:475:25)
    at C:\tools\fs\files.js:488:13
    at Array.forEach (native)
    at Object.files.cp_r (C:\tools\fs\files.js:475:25)
    at copyDirIntoTestRunnerApp (C:\tools\cli\commands.js:1692:15)
    at doTestCommand (C:\tools\cli\commands.js:1698:5)
    at Command.func (C:\tools\cli\commands.js:1533:10)
    at C:\tools\cli\main.js:1483:23
npm ERR! Test failed.  See above for more details.

Then meteor reset -> meteor npm install -> everything works
EDIT:

Aha! so two things the cmd being the way it is; legacy mode fixed that!
Another idea I am going to run with is running the test on port 4000 during build to not have to reset so much.


#11

This looks like a meteor 1.4 app, why don’t you try upgrading it first? there has been lots of improvements in between, especially on windows.


#12

This sounds like the same thing I found when Meteor automaticly updates the current version to 1.6, but you are in a folder using version number 1.5 or older. As to why does this or even how it could be doing this, I haven’t a clue.

The simplest workaround is to pipe your Meteor command through the “more” filter. I.E. meteor | more or meteor list | more.

I suspect reinstalling Meteor from Chocolatey would fix it too, but I have too many apps all over the place to test so I haven’t set aside the time to do that yet.


#13

Yes, its nice to just keep building sometimes. Haha.

Noted and thank you.

my next project I will start with the newest build of meteor.