How to prevent merging files in 1.3 when running in dev

I just upgraded to Meteor 1.3 and now when I run the “meteor” command, my browser is loading a merged version of all the javascript files “app.js” and a merged version of all the CSS files “merged-stylesheets.css”. How do I get it to load all the individual JS and CSS files? I’ve tried setting NODE_ENV=development, but it doesn’t make any difference.

Same stuff here. Plus no sourcemaps for coffee and stylus!

Just tested it with a generic app (meteor create smth) and there are no source files!

This is not just a windows issue guys :frowning:

Does nobody else from thousands of people who updated to 1.3 has this issue?

Do you have JavaScript and/or CSS source maps enabled in Chrome?

Mine are enabled.

This happened right after the update from 1.2 where no such problem existed.

Yes. I’m still not able to see the individual files. Everything is merged into app.js and I’ve been having to debug everything from the merged file rather than individual files. Works fine in Meteor 1.2, but not in 1.3.

There is a problem with source maps in 1.3 and 1.3.1; specifically, we stopped generating source maps for files that were identical to their source code, since source maps seemed pointless in those cases. However, thanks to feedback like yours, we’ve realized those source maps are still important, because they enable your browser to display individual files in a directory tree, rather than showing you the raw bundle. Combining files together into bundles is something we’ve been doing since before 1.2, but source maps restore the appearance of individual files.

This behavior will be restored in 1.3.2.


Incremental updates to Meteor are WAY BETTER than having to wait for a single big update!

Hmm, to temporarily mitigate the problem, could we prepend/append something like

const deleteMe = () => (null)

to the files that we want source mapped?

Still not done in … debugging is a pain. Any idea when this will make it back?

You might try deleting .meteor/local/bundler-cache to force rebundling?

I tried deleting .meteor/local/bundler-cache to force rebundling but it doesn’t work.
Why is it marked as fixed since April?

Also still having the issue in - makes it almost impossible to debug the front end :frowning:

+1 on this issue.
It is a pain to debug after migrating to 1.3 without source map.

It looks like it actually is working - however you know have to scroll to the bottom of sources and expand out the second “app” folder. The one at the top still shows the merged app.js file, but the one at the bottom is correctly source mapped.

Hope this helps!

A bug was submitted yesterday and it seems that it affects only Firefox.
This should be updated in Firefox 46.0
Meanwhile, Chrome is the fix.

Hi there ! Using and cleaned the cache-bundler, I see the app folder you are mentioning though I can only see CSS in there (Chrome), not JS.

Did you guys find a workaround to be able to debug using Breakpoints (for example) ?

Have we confirmed that this is fixed in 1.3.2_4? Coz I’m still having such issue here. Big app.js without individual source code.

So… has this been resolved since the OP or not?
I’m now making a final transition from 1.1 to 1.4 and am very surprised not to see my individual source files in chrome debugger - but a giant app.js instead.
Is this the expected behaviour of meteor build tool now??

seems like when using pure .js everything’s cool; the issue affects only .coffee files.