Meteor stuck at starting your app


#1

Hi I am new to meteor and when I tried to run meteor on my system, it occasionally starts which is very annoying.

It always stucks at starting your app and it does not start.

Also, It does not show any message like

==> started MongoDB.

I have to also clean my temporary files everytime to start meteor but it does not start.

I am a student and I need to work on meteor framework and it is killing me everyday,


Meteor starts only on port 3000, not any other port
#2

Try:

METEOR_PROFILE=1 METEOR_LOG=debug meteor --verbose


#3

I received the below error message

METEOR_PROFILE is not recognized as an internal or external
command,operable program or batch file


#4


#5

In Windows you need to do:

set METEOR_PROFILE=1
set METEOR_LOG=debug
meteor --verbose

#6

Thank you for your response. I tried the above commands but after all analysis , the meteor is still stuck at starting your app.


#7

@Atidivya I was having the same issue…stuck at Starting your app and this was a fresh download & installation (https://s3.amazonaws.com/meteor-windows/InstallMeteor.exe)

I was pointed to this is an issue related to Mongodb on stack overflow (http://stackoverflow.com/questions/36649478/meteor-application-stuck-at-starting-your-app-when-trying-to-run), but nothing conclusive.

So i downloaded mongodb latest msi - https://fastdl.mongodb.org/win32/mongodb-win32-x86_64-2008plus-ssl-3.2.7-signed.msi

Installed it but still stuck on Starting your App…

In Meteor app
Set the mongo url to empty to see if the trace changes… > set MONGO_URL=’ ’

run > meteor
Clearly it started showing some trace now.

So set the MONGO_URL to the path of the mongo db. set MONGO_URL=mongodb://localhost:27017/db

db is a folder I had created in my C:\data\db - which is where monogoDB looks for your database (db) by default in the data folder in the C root.

Then started mongodb seperately - it was in my C:/Program Files/MongoDB/Server/3.2/bin/ run>mongod.exe

Then tried running meteor again and vola…

PS: I did do a couple of meteor reset and meteor update and npm install to make all this go away , but i think finally it was the meteor + mongodb combination that worked and guess i will live with it for the time being till i can figure out a way to combine the two automatically. Some have suggested a restart will help iron out this issue. Will try that too and post back.


Stuck at "Starting your app"
#8

No not yet.

I am tried to install another windows on my virtual box and then install meteor again but no luck. It is still not working


#9

Did you try to see the mongodb resolution i have mentioned above.


#10

I am not able to set MONGO_URL on my terminal.

Whenever I give this command, it present nothing


#11

I had the same problem, but a simple

meteor reset

fixed it.

Update: I need to re-run this after every hot-reload (i.e. all the time). :fearful:


#12

I’m getting the same issue from time to time and have been employing the same workaround. Hope it doesn’t happen in production because I’m not sure meteor reset is something I can or want to be doing on a production server.


#13

I had this problem yesterday. I ran meteor reset which fixed the problem, but lost all my data as a consequence.

I hope it doesn’t happen again. Could this problem be fixed?


#14

@rafialikhan Thank you so much, this helped me to run meteor projects again. But I still can’t understand what or how did I cause this. Before I faced this issue I have made three small projects. Now when I want to run them, I have to manually start mongo db in one console, and run meteor in another. But if I create new project, I don’t have to run db myself, everything goes as before the issue. What do you think can cause this?
Thanks again for this post!!


#15

I also have same problem except meteor can start the app but without mongoDb

I installed meteor v1.4.1
on my 64 bit windows 7 machine.

I created an app named “myapp” by running “meteor.create.myapp” command and
the console displayed that my app is created

To this point everything was ok. and I tried to run myapp
using this two commands

cd myapp

meteor

It started processing……. And it showed me only

“=> proxy started”

and stacked at “starting your app”

I tried by restarting several times and with same result
stacked at “starting your app”

I finally uninstalled meteor and did fresh install but no
change.

After days of searching on google I found one solution from
this site

“echo %mongo_url%”

set mongo_url=mongodb://127.0.0.1:27017

and then meteor

It worked and started the app

But when I look at the console instead of starting the 3
components like this

“=> started proxy”

“=> started mongoDB”

“=> started your app”

It only started the two proxy & app but not mongoDb.

So meteor can`t start momngoDB.

I need your help any solution please?


#16

@brascene, @ermiasseife52 : if you have installed MongoDB separately from Meteor and/or set the MONGO_URL environment variable, you are telling Meteor to use the MongoDB instance you have installed. Meteor does not try to start this because it’s assumed to have been started beforehand (in Windows this would typically be an automatically started service) . Note the point about Meteor assuming a running MongoDB instance: if you don’t have that, your application will start, but will fail the first time the app tries to use the database.

If you don’t specify a MONGO_URL, Meteor tries to run a local (to this project) instance of MongoDB for you. This runs on your Meteor port + 1 (so frequently on port 3001) to avoid conflict with any other MongoDB instance available to you.


#17

So any fix on this issues?
My meteor stuck also at Starting your app.

I have even created a new meteor project from zero, same thing:
C:\bogdan\simple-todos>meteor
[[[[[ C:\bogdan\simple-todos ]]]]]

=> Started proxy.
Starting your app \

Note: the db folder in .meteor/local


#18

Mine too! I already reset it and also login the meteor but it’s still stuck


#19

same here >> i will try the mongodb solution as described above and tell the forum what happened.
none of my app is working even new test app with meteor create test_app
All sticking at STARTING YOUR APP.


#20

Hum, I had this issue with Meteor 1.5. Worked again after meteor update:

First failed:

$ meteor --settings settings.json
[[[[[ ~/Documents/repos/app ]]]]]          

=> Started proxy.                             
   [HMR] Dev server listening on port 3003
^C

Then update:

$ meteor update
This project is already at Meteor 1.5, the latest release.
                                                                                   
Changes to your project's package version selections from updating package versions:
                                              
babel-compiler             upgraded from 6.19.1 to 6.19.2
dynamic-import             upgraded from 0.1.0 to 0.1.1
ecmascript-runtime-client  upgraded from 0.4.1 to 0.4.2
email                      upgraded from 1.2.1 to 1.2.3
minimongo                  upgraded from 1.2.0 to 1.2.1
modules                    upgraded from 0.9.0 to 0.9.1

Started working:

$ meteor --settings settings.json
[[[[[ ~/Documents/repos/app ]]]]]          

=> Started proxy.                             
=> Started MongoDB.                           
   [HMR] Dev server listening on port 3003
=> Started your app.
=> App running at: http://localhost:3000/

Its interesting it didn’t seem to start mongo before I updated.