Problem update to 2.3

Hi everyone, I try to update meteor 2.3 from meteor 2.2.1 but got error , How to fix ?

Errors while initializing project:

While selecting package versions:
error: Conflict: Constraint accounts-base@1.0.1 is not satisfied by accounts-base 2.0.0.
Constraints on package "accounts-base":
* accounts-base@2.0.0 <- top level
* accounts-base@~2.0.0 <- top level
* accounts-base@2.0.0 <- service-configuration 1.1.0 <- accounts-base 2.0.0
* accounts-base@2.0.0 <- accounts-password 2.0.0
* accounts-base@1.7.1 || 2.0.0 <- matb33:collection-hooks 1.1.0
* accounts-base@1.0.1 <- cultofcoders:persistent-session 0.4.5
* accounts-base@1.7.1 || 2.0.0 <- apollo 4.1.0

Use accounts-base2.0.0 not 1.0.1 check your packages file and remove the version constraint

I checked on .meteor/version:


What happened if you run 2.0?

Tried to update

meteor update accounts-base
==>The specified packages are at their latest compatible versions.

But it not up to date accounts-base@1.9.0 ,then remove and add new add new but got error :

Have some constraints on accounts-password and collection-hooks etc you need to update all the packages so that it will work, it is a PITA but just the way it goes with updating bud

not work .
run meteor update --all-packages

Check the migration steps for version 2.3 in the changelog

You can ask the package owner of cultofcoders:persistent-session to update the package to the new major version of Accounts.

You can also opt to do that yourself by downloading the packages under your packages folder and do the migration steps yourself

Posted a how to fix topic here


Yeh that won’t work, if it did you would already have updated without error, the issue is you have to update each package from the backtrack there.

From what it says - it is the collection hooks, persistent sessions and Apollo that is causing the constraint. Update those then try again. If there is another error you must read it and act accordingly.

Yes, thank you. I will try it.

This is the problematic package. Everything else works with 2.0.0 as per your error message. eg. apollo says 1.7.1 || 2.0.0. So update the persistent-session and you should be good.


cultofcoders:persistent-session not yet up to date account-base to 2.0.0

Yes, I got error like that.

Did you follow the solution indicated in that post?

1 Like

Not yet, I will try it and confirm.

Afaik you don’t need persistent-sessions in 2.0.0 my sessions stay valid throughout rolling out updates on desktop and mobile I am logged in still with my same session from many months ago.

Best to just use session now

Session, as the name indicates, does not persist beyond browser sessions. If you close or reload your browser, Session will be reset.

Logins persist through local storage and not through Session. The package persistent-sessions persists sessions through the use of local storage.

1 Like

I didn’t get any error message when I upgraded our backend app to version 2.3.2, however the app is no longer starting up:

Starting inspector on failed: address already in use
W20210804-02:56:42.004(8)? (STDERR) /Users/andreaswest/.meteor/packages/meteor-tool/.
W20210804-02:56:42.004(8)? (STDERR) 						throw(ex);
W20210804-02:56:42.005(8)? (STDERR) 						^
W20210804-02:56:42.005(8)? (STDERR) 
W20210804-02:56:42.005(8)? (STDERR) TypeError: Cannot read property 'stream_server' of undefined
W20210804-02:56:42.005(8)? (STDERR)     at Object.Streamy.init (packages/yuukan_streamy.js:578:25)
W20210804-02:56:42.005(8)? (STDERR)     at onStartup (packages/yuukan_streamy.js:862:11)
W20210804-02:56:42.005(8)? (STDERR)     at Function.time (/Users/andreaswest/Documents/workspace/test2/.meteor/local/build/programs/server/profile.js:273:30)
W20210804-02:56:42.005(8)? (STDERR)     at /Users/andreaswest/Documents/workspace/test2/.meteor/local/build/programs/server/boot.js:415:15
W20210804-02:56:42.005(8)? (STDERR)     at /Users/andreaswest/Documents/workspace/test2/.meteor/local/build/programs/server/boot.js:465:7
W20210804-02:56:42.006(8)? (STDERR)     at (/Users/andreaswest/Documents/workspace/test2/.meteor/local/build/programs/server/profile.js:280:14)
W20210804-02:56:42.006(8)? (STDERR)     at /Users/andreaswest/Documents/workspace/test2/.meteor/local/build/programs/server/boot.js:463:13
=> Exited with code: 1
=> Your application is crashing. Waiting for file change.

Even when I take --inspect-brk=9229 out of my debug command it still claims the same error:

W20210804-03:06:28.215(8)? (STDERR) Starting inspector on failed: address already in use

W20210804-03:06:30.244(8)? (STDERR) /Users/andreaswest/.meteor/packages/meteor-tool/.

W20210804-03:06:30.245(8)? (STDERR) 						throw(ex);

Here’s the log from the upgrade itself:

Changes to your project's package version selections from updating the release:

accounts-base*             upgraded from 1.9.0 to 2.0.0
accounts-password*         upgraded from 1.7.0 to 2.0.0
babel-compiler             upgraded from 7.6.1 to 7.6.2
ddp-client                 upgraded from 2.4.0 to 2.5.0
ddp-rate-limiter           upgraded from 1.0.9 to 1.1.0
ddp-server                 upgraded from 2.3.2 to 2.4.0
dynamic-import             upgraded from 0.6.0 to 0.7.1
ecmascript                 upgraded from 0.15.1 to 0.15.2
ecmascript-runtime-client  upgraded from 0.11.0 to 0.11.1
ecmascript-runtime-server  upgraded from 0.10.0 to 0.10.1
email                      upgraded from 2.0.0 to 2.1.0
id-map                     upgraded from 1.1.0 to 1.1.1
matb33:collection-hooks    upgraded from 1.0.1 to 1.1.0
meteor-base                upgraded from 1.4.0 to 1.5.1
minifier-js                upgraded from 2.6.0 to 2.6.1
minimongo                  upgraded from 1.6.2 to 1.7.0
mongo                      upgraded from 1.11.0 to 1.12.0
mongo-id                   upgraded from 1.0.7 to 1.0.8
npm-bcrypt                 removed from your project
promise                    upgraded from 0.11.2 to 0.12.0
react-fast-refresh         upgraded from 0.1.0 to 0.1.1
service-configuration      upgraded from 1.0.11 to 1.1.0
socket-stream-client       upgraded from 0.3.1 to 0.4.0
srp                        removed from your project
standard-minifier-js       upgraded from 2.6.0 to 2.6.1
url                        upgraded from 1.3.1 to 1.3.2
webapp                     upgraded from 1.10.1 to 1.11.1

* These packages have been updated to new versions that are not backwards
test2: updated to Meteor 2.3.2.

Changes to your project's package version selections from updating package versions:

callback-hook        upgraded from 1.3.0 to 1.3.1
email                upgraded from 2.1.0 to 2.1.1
http                 upgraded from 1.4.3 to 1.4.4
meteortesting:mocha  upgraded from 2.0.1 to 2.0.2
npm-mongo            upgraded from 3.9.0 to 3.9.1
observe-sequence     upgraded from 1.0.16 to 1.0.19
routepolicy          upgraded from 1.1.0 to 1.1.1

The following top-level dependencies were not updated to the very latest version available:
 * lmieulet:meteor-coverage 3.2.0 (4.0.0 is available)

Newer versions of the following indirect dependencies are available:
 * blaze 2.3.4 (2.5.0 is available)
 * blaze-tools 1.0.10 (1.1.2 is available)
 * html-tools 1.0.11 (1.1.2 is available)
 * htmljs 1.0.11 (1.1.1 is available)
 * http 1.4.4 (2.0.0 is available)
 * spacebars 1.0.15 (1.2.0 is available)
 * spacebars-compiler 1.1.3 (1.3.0 is available)
These versions may not be compatible with your project.
To update one or more of these packages to their latest
compatible versions, pass their names to `meteor update`,
or just run `meteor update --all-packages`.
➜  test2 git:(master) ✗ meteor --version
Meteor 2.3.2

Any idea why the app is now crashing?

Interesting, mine does on all my apps! I am still logged in after 3 months of non activity I just checked to verify. It has always persisted for me since like meteor 0.8 or something many years ago